The Joomla! Community Magazine™

Quale versione Joomla! scegliere ?

Written by | Monday, 01 August 2011 00:00 | Published in 2011 August
Alla luce del susseguirsi dei rilasci di nuove versioni Joomla, due nell' arco di sei mesi (la 1.6 a gennaio e la 1.7 a luglio e prossimamente la 1.8 a gennaio 2012) negli utilizzatori stà crescendo fortemente la domanda su quale versione di Joomla! utilizzare per il proprio sito.
Ciclo di sviluppo Ciclo di sviluppo

Cercherò in queste righe di mettervi nella condizione di poter rispondere alla domanda con cognizione di causa, vi anticipo fin da ora che non esiste un unica risposta valida per tutte le situazioni, ma la stessa va ricercata effettuando una approfondita analisi delle vostre esigenze avendo appunto conoscenza di cosa c'è di nuovo nelle versioni di Joomla! a partire dalla 1.6.

Nuovo ciclo di sviluppo

Il primo fattore che dobbiamo conoscere è il nuovo ciclo di sviluppo intrapreso da joomla!, a partire dall'uscita di Joomla 1.6 lo scorso Gennaio è stato messo in pratica il ciclo di sviluppo alla "Ubuntu"

con rilasci prefissati:

  • ogni 6 mesi il rilascio della versione  STS Short Term Support
  • ogni 18 mesi il rilascio della versione LTS Long term Support.

joomla_release_dates

Cosa c'è di nuovo

Numerose sono le "features" introdotte a partire dal rilascio della versione 1.6, infatti non a caso la 1.6 segna un importante passo in avanti rispetto alla precedente e gloriosa 1.5, proverò ad elencarvi le più importatnti:

  • un nuovo sistema per la gestione degli accessi, Access Control List (ACL)
  • un nuovo sistema dei Permessi
  • gestione di categorie ed eventuali sottocategorie, entrambe illimitate
  • nuovi strumenti per SEO
  • migliorato supporto nativo per il multilingua
  • migliorata l'interfaccia di amministrazione
  • migloramenti  nel core output ora XHTML 1.0
  • Template overrides e Layout overrides
  • aggiornamento delle extensions
  • aggiornamento versioni Joomla
  • Joomla Platform

l'elenco potrebbe continuare ancora per alcune pagine per approfondimenti sulle novità vi invito a leggere gli annunci ufficiali

Retro compatibilità

Anche se non si evince chiaramente, tra tutte le novità introdotte non è stata prevista la retro compatibilità, come invece fu fatto al tempo del passaggio dalla 1.0 alla 1.5, in pratica estensioni, template e quant'altro gira sulla 1.5, non sono compatibili con la 1.6 e succesive.

Cosa fare

Per effettuare una scelta consapevole, a mio avviso, restano ancora alcune variabile da analizzare :

  • avete già un sito Joomla
  • tipologia sito
  • che utente siete

Se dovete partire da zero la scelta più ovvia è quella di partire con la versione più nuova a disposizione, ma , prima di optare per l'ultima versione disponibile, al momento in cui scrivo la 1.7, dovreste chiedervi se avete bisogno di alcune estensioni in particolare, come ad esempio per l'e-commerce, in questo caso molto probabilmente può essere conveniente puntare ancora sulla 1.5 in quanto tutte le estensioni sono sicuramente compatibili con la 1.5 ma non tutte sono ancora compatibili con la 1.7, d'altronde la 1.5 è una LTS è sara sviluppata almeno fino ad Aprile 2012.

Viceversa se già avete un sito basato sulla 1.5 la faccenda si complica, entrano in gioco altri fattori, come la tipologia del vostro sito, e sopratutto la vostra esperienza. Conosco persone che sono soddisfatte del loro sito basato sulla 1.0 e non hanno nessuna voglia o necessità di cambiare, pertanto dovete anche chiedervi perchè voglio cambiare ?, un vecchio adagio dice che: "se qualcosa funziona ..."

Nell'ipotesi in cui abbiate deciso di passare alla nuova versione di Joomla!, ed abbiate già verificato la compatibilità delle estensioni che utilizzate, un domanda da porsi è quando fare il grande passo, tenete presente come già accennato, che il ciclo di vita della 1.5 terminerà in Aprile 2012 e che quindi sarà supportata anche dopo il rilascio della l'altra LTS presumibilmente la 1.8 che verrà rilasciata in Gennaio 2012, pertanto c'è tempo, dipendentemente dalla vostra esperienza conviene a mio avviso passare da una LTS la 1.5 all'altra la 1.8 appunto, le STS come la 1.6 e la 1.7 sono per utenti esperti, sviluppatori, quindi se non vi riconoscete in una di queste due categorie, il consiglio è di attendere la 1.8, almeno farete il lavoro di migrazione una volta sola. Se proprio non riuscite ad attendere e volete tuffarvi nel nuovo corso, una raccomandazione è d'obbligo, fate prima di tutto un backup del  vostro sito, anche se può sembrare banale, essendo una delle regole più semplici da seguire,  puntualmente viene disattesa, effettuate dei test sul funzionamento del vostro in locale e solo quando tutto vi sembra ok, portatelo finalmente live.

Conclusioni

Spero che queste righe vi siano utili per prendere la vostra decisione, tanto non c'è fretta, ponderate bene la vostra scelta in considerazione anche del fatto che non esiste un downgrade.

Read 9672 times

Related Video

Tagged under Italian

Language Switcher

Current Articles

JCM international articles

Join us at the Joomla! World Conference 2014, Grand Oasis Cancun, Mexico November 7-9, 2014

Grab the Joomla! Community Banners! Spread the word!

Recommend us on Google+