The Joomla! Community Magazine™

Issue 2014 May > French

Joomla! 3.3, Joomla! 3.4 et la nouvelle feuille de route Joomla!

Written by | Thursday, 01 May 2014 00:00 | Published in 2014 May
Le mois d'avril a été très riche pour Joomla!, avec trois évènements importants. Le 5 avril, la PLT (Production Leadership Team) a annoncé qu'une version 3.4 verrait le jour dans le courant du mois de juillet 2014 (normalement le 15 juillet). Au travers de ce communiqué, la PLT a également annoncé la modification de la feuille de route de sortie des versions. Et enfin, fin avril, la version 3.3 stable de Joomla! a été mise à disposition apportant plusieurs nouvelles fonctionnalités. Après toutes ces annonces, où en sommes-nous ?

Joomla! 3.4

Le 5 avril, la PLT a donc annoncé, prenant de court de nombreux utilisateurs, qu'une version 3.4 verrait le jour dès le mois de juillet prochain. Cette annonce a en effet surpris nombreux d'entre nous, car pour beaucoup la version 3.3 de Joomla! devait être la dernière version STS et devait déboucher sur Joomla! 3.5, dont la sortie était prévue en fin d'année 2014, qui aurait été la prochaine version LTS de Joomla! et donc supportée pour environ 2 ans. Dans ce même article, la PLT a également annoncé que la feuille de route de version de Joomla! serait modifiée et qu'elle serait bientôt communiquée.

Objectifs

Les objectifs de cette version 3.4 seront les suivants :

Continuer l'implémentation des Microdata

La version 3.2 a introduit l'utilisation des Microdata dans Joomla! grâce à la librairie JMicrodata. Le but est donc de continuer cette implémentation afin d'améliorer les possibilités SEO offertes nativement par Joomla!. 

Edition des modules en Frontend

La version 3.2 a également apporté plus de possibilités pour administrer un site Joomla! depuis le Frontend (sans avoir à se connecter à l'administration). Un des buts de la version 3.4 serait de finaliser l'édition de module via le Frontend.

Découpler com_weblink

Actuellement, le CMS Joomla! est composé de plusieurs extensions qui, si elles ne sont pas utilisées, ne peuvent pas facilement être désinstallées proprement sans causer de problèmes lors des prochaines mises à jour. La PLT aimerait donc travailler à proposer une distribution plus légère qui ne comporterait pas certaines extensions (comme par exemple le composant liens web). Ces composants pourraient être installés, s'ils sont nécessaires au site web, via l'onglet "Installer à partir du web". Une catégorie du JED pourrait être réservée à ces composants.

 

Joomla! 3.3

Annoncée en début d'année 2014, le mois d'avril a également permis de finaliser la version 3.3 de Joomla!.

Plusieurs nouveautés

Une sécurité accrue

Comme annoncé sur ce billet de Michael Babker, la version php minimale requise pour Joomla! 3.3 est la version 5.3.10. Cela permet d'améliorer sensiblement le niveau de cryptage qui peut être utilisé pour la sécurité des mots de passe.

Cloud Storage APIs

Il sera désormais possible de faire interagir un site Joomla! avec Amazon S3 ou d'autres fournisseurs de stockage sur le cloud.

Mootools vers jQuery JavaScript

Un important travail a été réalisé pour passer de MooTools vers jQuery JavaScript, ce qui va permettre de réduire la taille des sites web Joomla! en ne chargeant que JQuery ainsi que de bénéficier de tous les avantages proposés par JQuery.

 

Nouvelle feuille de route

La PLT, qui s'occupe de la feuille de route des versions de Joomla!, souhaite donc modifier cette feuille de route dans le but de permettre un développement continu et plus flexible du projet, en particulier pour le CMS.

LTS/STS vs Version Mineure/Version Majeure

En annonçant la sortie de la version 3.4, la PLT a donc décidé de se séparer du système STS/LTS que Joomla! connaissait depuis la version 1.6. Auparavant les versions STS (Short Term Support ou Support à Court Terme en français 1.6, 1.7, 3.1, 3.2, etc) étaient supportées pendant environ 6-8 mois puis elles laissaient place aux versions LTS (Long Term Support ou Support à Long Terme en français, 2.5) qui étaient elles supportées sur une période plus longue, environ 18-24 mois.

Désormais, ce système est donc abandonné. Il laisse place à un système de Versions Majeures (comme par exemple les versions 3, 4, etc) et de Versions Mineures (comme par exemple les versions 3.1, 4.2, etc).
La dernière Version Mineure d'une version Majeure est désormais supportée pendant 2 ans à partir de sa date de sortie.

Ce nouveau système donne la possibilité à l'équipe de développement d'ajouter de nouvelles fonctionnalités sur des versions mineures, sans devoir attendre la prochaine version majeure. Le projet n'est donc plus "bloqué" sur un cycle de version.

Pour résumer :

  • Version 4 : Version Majeure.
  • Version 4.1 : Version Mineure.
  • Version 4.1.1 : Mise à jour de sécurité ou de correctif de bug.

 

Ce nouveau changement de la feuille de route apporte plusieurs questions :

Q : La version 3.5 sera-t-elle la version LTS (ou la dernière Version Mineure) du cycle 3.x et donc supportée sur 2 ans?

R : Non. Les stratégies de sortie des versions ont été modifiées afin de ne pas se verrouiller sur une version spécifique. En vertu de la stratégie révisée, sauf si remplacée par une nouvelle version mineure, il y aura au moins deux années de soutien pour la dernière mise à jour mineure d'une série. Par exemple, si 3.4 était la dernière Version Mineure de la série 3.x, elle serait supportée pour au moins les deux prochaines années à venir.

 

Q : Pourquoi cesser la stratégie LTS X.5 ?

R : La stratégie LTS X.5 empêche la PLT de délivrer des versions supplémentaires sur une série de version majeure. Si 3.5 était la version LTS pour la série 3.x, comme cela était initialement prévu, alors aucune nouvelle fonctionnalité ou amélioration ne pourrait être ajoutée avant que le développement de la série 4.0 ne commence. Désormais, il est possible de continuer le développement de la série 3.x sans se bloquer à une version LTS spécifique, ce qui permet une période de support plus longue pour la série 3.x.

 

Q : Qu’advient-il de la version 3.5 annoncée ?

R : Ce sera une autre Version Mineure de la série 3.x. A l’heure actuelle, aucune date n’a été fixée.

 

Q : Mon site est sous Joomla 2.5, que puis-je faire ?

R : La version 2.5 est la version LTS actuelle, elle serait donc supportée jusqu'à la fin de l'année 2014. Ensuite, il sera nécessaire de migrer ce site vers la dernière Version Mineure de la Version Majeure 3.

 

Il est important de comprendre, je pense, que ce système ne va en rien modifier la stabilité du cycle STS/LTS. De nombreux utilisateurs ne savent plus quoi faire car ils attendaient la sortie de Joomla! 3.5 pour migrer leurs sites sous 2.5 (ou même 1.5 pour certains) directement vers cette version, sans avoir à passer par toutes les versions STS (3.0, 3.1, etc). Ces utilisateurs devront simplement patienter jusqu'à la dernière Version Mineure de la Version Majeure 3 pour faire leur migration. Et cette Version Mineure sera supportée au moins deux ans.

Read 6220 times
Tagged under French

Language Switcher

Current Articles