The Joomla! Community Magazine™

Issue 2014 April > French

Encore sous Joomla! 1.5, il devient urgent de migrer

Written by | Tuesday, 01 April 2014 00:00 | Published in 2014 April
Il y a deux ans et demi, Joomla.org nous annonçait la fin du support officiel de Joomla! 1.5 stable, le 1er mars dernier c'était au tour des archives d'extensions de cette branche sur le JED (Joomla! Extensions Directory). Une suite logique dans l'évolution du projet. Actuellement la version stable avec un support à long terme (LTS) est la branche 2.5 et dans quelques mois ce sera au tour de Joomla! 3.5 de prendre le relais. Notre CMS est en constante évolution c'est un fait, mais près de 50 % des sites sont encore sous Joomla! 1.5 et là, ça devient un problème.
Encore sous Joomla! 1.5, il devient urgent de migrer Illustration par Helvecio da Silva

Quels sont les risques?

Actuellement Joomla! 1.5.26 avec le dernier patch de sécurité reste encore une version stable, mais il faut être bien conscient qu'aucun correctif officiel ne sera produit lors de la prochaine faille, même mineure.

Concernant les extensions : composants, plugins, modules et templates, c'est un peu comme si l'on jouait à la roulette russe. Il reste encore des extensions fiables pour Joomla! 1.5, mais pour combien de temps, je ne pourrais vous le dire.

Depuis deux ans, j'ai pu constater sur beaucoup de mes interventions bon nombre de fichiers vérolés à des fins de piratage indirect (phishing) ou pour du référencement sauvage à l'insu des utilisateurs.

La diffusion des extensions pour Joomla! 1.5

Concrètement, il ne reste quasiment plus d'éditeur mettant à jour leurs développements pour cette branche 1.5, mais alors pourquoi tant d'archives sont encore présentes sur des sites d'éditeurs, de support ou de création de sites sachant que certaines sont potentiellement dangereuses ?

Chaque site se doit d'assumer ce qu'il diffuse en connaissance de cause, c'est bien pour cela que nous ne proposons plus que des traductions car les risques sont effectivement bien présents. Fort de ce constat, je pense que vous comprendrez mieux pourquoi le JED a choisi de fermer définitivement ses archives d'extensions pour Joomla! 1.5.

Hébergement et responsabilités

De plus en plus d'hébergeurs ferment tout bonnement les sites responsables contenant des failles ou plus à jour, souvent sans explication envers les pauvres webmasters amateurs qui ne comprennent pas toujours le pourquoi.

Doit-on blâmer les fournisseurs d'accès qui souhaitent épurer leurs serveurs ?

Je ne le pense pas, car dès lors que l'on administre un site web on a des responsabilités : le mettre à jour régulièrement, le surveiller et rester informé des conséquences qui peuvent en découler en cas de non suivi.

Il est facile de critiquer tel ou tel hébergeur sur ses lenteurs, il faut savoir que des sites piratés (exemple : les sites zombies) influent grandement sur les performances d'un serveur où vous pouvez être hébergé. Il est logique pour les fournisseurs de prendre des décisions drastiques pour garantir aux autres utilisateurs la qualité de services auxquels ils ont souscrit.

Il faut migrer

Je comprends que le mot de Migration fait peur aux administrateurs de sites sous Joomla! 1.5, à juste titre si l'on a déjà vécu le passage de Joomla! 1.0 à Joomla! 1.5  car il faut bien l'avouer, c'était une galère.

Je sais que ce sera pour beaucoup encore un passage pénible, mais si je peux vous rassurer ou vous conforter, le passage de Joomla! 2.5 vers Joomla! 3 est de mon point de vue plus simple.

Vous pouvez vous faire aider

Un petit conseil si vous choisissez un prestataire pour vous aider, renseignez-vous bien avant sur ses compétences et sur les tarifs qui peuvent être conséquent. Vous trouverez de bons professionnels sur les forums dédiés à Joomla, mais attention j'ai vu des offres low cost qu'il faut éviter de mon point de vue, des migrations à 50€ je n'y crois pas.

Conclusion

Je vais bientôt clore cet article en souhaitant ne pas vous avoir trop fait peur. Je vous laisse juge concernant mon plaidoyer sur l'évolution des sites qui sont toujours sous Joomla! 1.5.

Pour ma défense

Mon constat sur la situation reste une approche très personnelle, mais à mon avis, pas si éloigné de la réalité, mes réflexions pourront paraître très abruptes pour certains, voire sans concession pour d'autres. Je vois trop souvent ce type de remarque "Il faut faire comme cela" ou "Nous vous conseillons", c'est tellement simple de le dire alors que l'on n'est pas capable de l'appliquer soi-même.

Voilà j'assume sans problème ce que je publie, car on ne pourra pas me dire : "Je ne le savais pas".

En résumé

Il devient urgent de migrer, l'opération n'est pas simple, mais nous nous devons de donner une bonne image de notre CMS, tenir à jour nos sites c'est notre responsabilité.

Read 2591 times
Tagged under French
Bourderiou Stéphane

Bourderiou Stéphane

Fondateur du site Aide-Joomla.com. Depuis 2006 j'essaie de faire partager ma passion pour Joomla au travers d'actualités, de tutoriels et de traductions d'extensions.

Language Switcher

Current Articles